Extensões do GNOME via Github

Quem nunca se estressou ao atualizar o GNOME e ver suas extensões favoritas deixarem funcionar?! Agora vou repassar um método de instalação para toda e qualquer extensão do GNOME que esteja no GITHUB. É mamão com açúcar. 😉

  1. O primeiro passo é acessar o site das extensões do GNOME, pesquisar pela extensão desejada e acessar o endereço da mesma no github. Como exemplo, utilizarei a Show Desktop from Overview. (Uso muito essa extensão!) Obs.: Não se esqueça de selecionar no site, a opção Compatible with => ALL Versions. Desta forma a extensão será exibida, mesmo que não seja compatível com a versão do seu GNOME.
  2. Acesse a página da extensão no github, neste caso: https://github.com/Bazon/ShowDesktopFromOverview e em seguida baixe a mesma clicando em Download ZIP.
  3. Uma vez efetuado o download, descompacte-a e mova a pasta extraída para o diretório das extensões do GNOME que fica localizada em /home/<usuário>/.local/share/gnome-shell/extensions – Todo esse processo pode ser feito através do Nautilus (Gerenciador de Arquivos do GNOME).
  4. Acesse esta pasta e abra o arquivo metadata.json, para copiar o UUID informado no mesmo. Este deverá ser o nome da pasta da extensão, renomeie-a! Neste exemplo a pasta mudará de ShowDesktopFromOverview-master para ShowDesktopFromOverview@bazonbloch.arcor.de
  5. Agora vamos abrir o editor do Dconf, pressionar Ctrl + F para localizar a opção validation, ativar assim a opção disable-extension-version-validation, desta forma será ignorada a versão do seu GNOME para instalar as extensões. Caso não tenha o Editor do Dconf instalado, instale através do pacote dconf-editor.
  6. Em seguida, devemos reiniciar o GNOME-Shell, basta pressionar ALT + F2, digitar a letra r e apertar o <ENTER>.
  7. Estamos quase lá! Execute a Ferramenta de ajustes do GNOME (Tweak tool – Instalado através do pacote gnome-tweak-tool, caso não esteja instalado na sua distribuição Linux) e habilite sua extensão. 😉

Voilà! A extensão funcionará sem problemas.

Anúncios
Extensões do GNOME via Github

Instalando o Megasync (Distros baseadas no Arch Linux)

megaOlá!

Para instalar o MEGA é bem simples! Primeiramente, vamos instalar o YAOURT! Uma interface para o pacman que adiciona acesso automatizado ao AUR. (Caso já o tenha instalado, pule para o passo 2):

Passo 1: Instalando o yaourt:

sudo pacman -Sy yaourt

Passo 2: Com o yaourt instalado, vamos baixar somente o pkgbuild do megasync:

yaourt -G megasync

Passo 3: Uma vez baixado, será criado um diretório megasync no diretório atual ou em /tmp/yaourt-tmp-<nome do usuário>/ . Dentro da pasta, é hora de instalar ignorando o checksum:

makepkg -i –skipinteg PKGBUILD

Caso seja informado que dependências estão faltando (c-ares e crypto++), basta instalar as mesmas através do pacman e executar o passo 3 novamente.

Agora é só configurar sua conta e aproveitar o serviço! T

 

Instalando o Megasync (Distros baseadas no Arch Linux)

Correção de erro gráfico no GNOME 3.18.1

Ao atualizar o GNOME para a versão 3.18.1 no Manjaro, no primeiro boot depois da atualização ao clicar no botão Atividades, as janelas abertas apresentam um erro gráfico, as mesmas ficam com rastro.

Solução:

  • Instalar o bash script Downgrade:

sudo pacman -S downgrade

  • Executar o drowngrade do COGL (Biblioteca para o uso de  hardware de gráficos 3D):

downgrade cogl

  • Escolha a versão cogl-1.22.0-1-x86_64.pkg.tar.xz (remoto) e adicione o mesmo no IgnorePkg.

Agora é reiniciar e seu sistema estará funcionando 100%. Até a próxima…

Correção de erro gráfico no GNOME 3.18.1